Проблема с абзой данных после установки модуля

Антиспам МОД для phpBB3, расширение (модуль) для phpbb3.1
User avatar
joic
Posts: 3
Joined: 18 Jan 2015, 11:59
Has thanked: 2 times
Been thanked: 1 time

Проблема с абзой данных после установки модуля

Unread post by joic » 18 Jan 2015, 12:03

Здравствуйте, возникло такое окно после утсановки через автомод:

Code: Select all

Общая ошибка
SQL ERROR [ mysql4 ]

Unknown column 'ct_submit_time' in 'field list' [1054]

SQL

UPDATE phpbb_sessions SET ct_submit_time = 1421582286 WHERE session_id = '6a06e46a63ce715bcfa9be79abb7c781'

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/includes/db/dbal.php
LINE: 757
CALL: trigger_error()

FILE: [ROOT]/includes/db/mysql.php
LINE: 193
CALL: dbal->sql_error()

FILE: [ROOT]/includes/cleantalk.php
LINE: 156
CALL: dbal_mysql->sql_query()

FILE: [ROOT]/posting.php
LINE: 640
CALL: ct_set_submit_time()
Причем форум открывается, но при нажатии на кнопку ответить или цитировать, появляется данная информация.
Модуль CleanTalk работал нормально, но на днях стал выдавать ошибку. В чем проблема может быть и как ее устранить?
При деинсталляции мода, все работает отлично.

User avatar
znaeff
Posts: 318
Joined: 06 Jul 2012, 04:24
Has thanked: 1 time
Been thanked: 21 times
Contact:

Re: Проблема с абзой данных после установки модуля

Unread post by znaeff » 19 Jan 2015, 11:19

Если при переустановке модуля ошибка сохраняется, добавьте в таблицу "phpbb_sessions"
поле "ct_submit_time" тип INT:11 по умолчанию 0.
Alex Znaev,
http://cleantalk.org
server and client applications development

User avatar
joic
Posts: 3
Joined: 18 Jan 2015, 11:59
Has thanked: 2 times
Been thanked: 1 time

Re: Проблема с абзой данных после установки модуля

Unread post by joic » 19 Jan 2015, 12:57

znaeff wrote:Если при переустановке модуля ошибка сохраняется, добавьте в таблицу "phpbb_sessions"
поле "ct_submit_time" тип INT:11 по умолчанию 0.
Огромное спасибо, создал столбец ct_submit_time с таким именем в таблице phpbb_sessions и теперь сообщения нормально добавляются. Еще раз спасибо. Только вот не знаю правильно ли это, но установил версию модуля 4.1, а показывает что установлена версия 3.75. Или за новую версию нужно будет новую оплату вносить?

User avatar
znaeff
Posts: 318
Joined: 06 Jul 2012, 04:24
Has thanked: 1 time
Been thanked: 21 times
Contact:

Re: Проблема с абзой данных после установки модуля

Unread post by znaeff » 20 Jan 2015, 12:00

Нет, не нужно. Вы же оплачиваете подключение к нашему сервису, а не модуль.
These users thanked the author znaeff for the post:
joic (22 Jan 2015, 16:19)
Rating: 50%
Alex Znaev,
http://cleantalk.org
server and client applications development

User avatar
shagimuratov
Administrator
Posts: 1115
Joined: 16 Mar 2011, 12:51
Has thanked: 158 times
Been thanked: 67 times
Contact:

Re: Проблема с абзой данных после установки модуля

Unread post by shagimuratov » 20 Jan 2015, 13:52

joic wrote:Только вот не знаю правильно ли это, но установил версию модуля 4.1, а показывает что установлена версия 3.75.
До версии 4.1 использовали версию 3.75 на форуме? Если так, то необходимо обновить данные модуля в БД для этого,

1. Скопируйте папку root/install из арихва с модулем 4.1 в корень форума.
2. Выполните обновление настроек модуля в БД,

http://YOUR-WEBSITE.RU/phpbb3/install/index.php

Получилось?
These users thanked the author shagimuratov for the post:
joic (22 Jan 2015, 16:19)
Rating: 50%
WBR
Denis Shagimuratov
Project leader

User avatar
joic
Posts: 3
Joined: 18 Jan 2015, 11:59
Has thanked: 2 times
Been thanked: 1 time

Re: Проблема с абзой данных после установки модуля

Unread post by joic » 22 Jan 2015, 16:02

shagimuratov wrote: 1. Скопируйте папку root/install из арихва с модулем 4.1 в корень форума.
2. Выполните обновление настроек модуля в БД,

http://YOUR-WEBSITE.RU/phpbb3/install/index.php

Получилось?
В общем получилось, обновилось до версии 4.1, но теперь не входит под главным администратором на сайт.
Пришлось из базы данных удалить столбец ct_submit_time, которую ранее создавал и теперь все заработало.
Причем столбец по правильному должен все таки называться session_ct_submit_time, но и без него вроде пашет все.
Спасибо.
These users thanked the author joic for the post:
shagimuratov (23 Jan 2015, 07:33)
Rating: 50%

Locked