Still getting 'Not Connected' after many days

Anti-spam MOD for phpBB3, extension for phpbb3.1
techdev
Posts: 5
Joined: 10 Sep 2014, 01:04
Has thanked: 0
Been thanked: 0

Still getting 'Not Connected' after many days

Unread post by techdev » 13 Sep 2014, 01:30

I have phpBB 3.0.12 (current latest version). The Clean Talk install seems to have gone fine as I can see that in my '.MODS tab in the ACP. I have entered my access key and I see my sites in the Clean Talk control panel. The only problem is that they both show up as 'Not Connected'. I realized I hadn't done the test registraion, and tried to do that to see if that would help. Unfortunately, both my sites do not let me do the test registration with the test email address (stop_email@example.com) and come up with a '500 - Internal Server Error' when I register with that email address. My sites are listed below

http://techdevforums.com
http://thenriforum.com

So, Clean Talk is not active for my sites and I'm getting spam registrations galore as usual (and the only way I'm preventing spam registrations is by allowing users to be activated only by the admin). I did subscribe for the 3 sites package and already made my payment a few weeks ago. Thanks for your help.

User avatar
shagimuratov
Administrator
Posts: 1115
Joined: 16 Mar 2011, 12:51
Has thanked: 158 times
Been thanked: 67 times
Contact:

Re: Still getting 'Not Connected' after many days

Unread post by shagimuratov » 13 Sep 2014, 04:45

Hi,

Did you install the mod via Automod? Can you please check webserver logs are there any lines with message?

Code: Select all

PHP Fatal error
Thanks!
WBR
Denis Shagimuratov
Project leader

techdev
Posts: 5
Joined: 10 Sep 2014, 01:04
Has thanked: 0
Been thanked: 0

Re: Still getting 'Not Connected' after many days

Unread post by techdev » 13 Sep 2014, 19:03

Yes, I did install it via Automod. I am hosting phpBB from GoDaddy, so can you please provide guidance on how I can obtain the webserver logs for a hosted environment. I will check with Godaddy but your advise is appreciated too.

User avatar
shagimuratov
Administrator
Posts: 1115
Joined: 16 Mar 2011, 12:51
Has thanked: 158 times
Been thanked: 67 times
Contact:

Re: Still getting 'Not Connected' after many days

Unread post by shagimuratov » 14 Sep 2014, 03:50

Ok, use this manual to enable PHP error logs,

https://support.godaddy.com/help/articl ... -in-cpanel

Or use this if you have already enabled logs,

https://support.godaddy.com/help/articl ... error-logs

Does it help?
WBR
Denis Shagimuratov
Project leader

techdev
Posts: 5
Joined: 10 Sep 2014, 01:04
Has thanked: 0
Been thanked: 0

Re: Still getting 'Not Connected' after many days

Unread post by techdev » 15 Sep 2014, 04:39

Actually,I did look further in my phpBB admin and I found the error logs in phpBB ACP itself. I hope that's the one you're referring to. I found only two types of recurring errors in the logs (below). They seem to be referring to email, however I get the registration emails from the board fine.

Anonymous 195.211.155.138 Thu Sep 11, 2014 7:36 pm E-mail error
EMAIL/PHP/mail()
/ucp.php

Errno 2: mail(): Failed to connect to mailserver at "relay-hosting.secureserver.net" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() at [ROOT]/includes/functions_messenger.php line 1680

Anonymous 195.211.155.143 Thu Sep 11, 2014 4:54 pm E-mail error
EMAIL/PHP/mail()
/ucp.php

Errno 2: mail(): Failed to Receive at [ROOT]/includes/functions_messenger.php line 1680

User avatar
shagimuratov
Administrator
Posts: 1115
Joined: 16 Mar 2011, 12:51
Has thanked: 158 times
Been thanked: 67 times
Contact:

Re: Still getting 'Not Connected' after many days

Unread post by shagimuratov » 15 Sep 2014, 05:49

Thanks for these logs, but I don't think thats is the reason of 500 error.

In the logs should be notices regarding to PHPBB_ROOT/ucp/ucp_register.php. So, did you find any PHP error logs in GoDaddy CP?
WBR
Denis Shagimuratov
Project leader

techdev
Posts: 5
Joined: 10 Sep 2014, 01:04
Has thanked: 0
Been thanked: 0

Re: Still getting 'Not Connected' after many days

Unread post by techdev » 17 Sep 2014, 12:58

I did not find the PHP error logs using your instructions above, and I believe that may be because I have a windows hosting plan (plesk panel) with GoDaddy. It is set up to run PHP apps like phpBB. I tried to find the option to turn on the error logging for phpbb but could not find any such option.

If we assume that the error does exist in the log, can you advise why cleantalk on my site is 'not connecting' to the central clean talk site what the possible resolution can be.

User avatar
shagimuratov
Administrator
Posts: 1115
Joined: 16 Mar 2011, 12:51
Has thanked: 158 times
Been thanked: 67 times
Contact:

Re: Still getting 'Not Connected' after many days

Unread post by shagimuratov » 17 Sep 2014, 16:30

Ok, lets set phpBB debuggin system, please add or uncomment lines in PHPBB_ROOT/config.php,

Code: Select all

@define('DEBUG', true);
@define('DEBUG_EXTRA', true);
Then try new dummy signup. Have any error notices?
WBR
Denis Shagimuratov
Project leader

techdev
Posts: 5
Joined: 10 Sep 2014, 01:04
Has thanked: 0
Been thanked: 0

Re: Still getting 'Not Connected' after many days

Unread post by techdev » 18 Sep 2014, 16:26

I uncommented the two lines in both sites and now I'm not getting an error when I'm doing the test registration with stop_email@example.com. The registration is going through fine and even CleanTalk is not catching it.

User avatar
shagimuratov
Administrator
Posts: 1115
Joined: 16 Mar 2011, 12:51
Has thanked: 158 times
Been thanked: 67 times
Contact:

Re: Still getting 'Not Connected' after many days

Unread post by shagimuratov » 18 Sep 2014, 17:14

Just a moment, please let me check our servers logs.
WBR
Denis Shagimuratov
Project leader

Locked