Registration submission gets SQL error

Anti-spam MOD for phpBB3, extension for phpbb3.1
Ken
Posts: 4
Joined: 03 Nov 2016, 17:58
Has thanked: 0
Been thanked: 0

Registration submission gets SQL error

Unread post by Ken » 03 Nov 2016, 18:04

1. Site URL: forums.oausa.net
2. CMS name: PHPBB 3.1.10
3. URL of page with the registration form: http://forums.oausa.net/ucp.php?mode=register

When you try to register, it spits out an error with a backtrace. If I disable the CleanTalk extension the error goes away.

Here's a copy of the backtrace:

General Error

SQL ERROR [ mysql4 ]

Unknown column 'ct_submit_time' in 'field list' [1054]

SQL

UPDATE 4x4bb_sessions SET ct_submit_time = 1478196059 WHERE session_id = 'fbe4c3ff60ca8012ca09bb848e56400e'

BACKTRACE


FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/phpbb/db/driver/driver.php
LINE: 855
CALL: trigger_error()

FILE: [ROOT]/phpbb/db/driver/mysql.php
LINE: 181
CALL: phpbb\db\driver\driver->sql_error()

FILE: [ROOT]/phpbb/db/driver/factory.php
LINE: 329
CALL: phpbb\db\driver\mysql->sql_query()

FILE: [ROOT]/ext/cleantalk/antispam/model/main_model.php
LINE: 216
CALL: phpbb\db\driver\factory->sql_query()

FILE: [ROOT]/ext/cleantalk/antispam/event/main_listener.php
LINE: 119
CALL: cleantalk\antispam\model\main_model::set_submit_time()

FILE: (not given by php)
LINE: (not given by php)
CALL: cleantalk\antispam\event\main_listener->form_set_time()

FILE: [ROOT]/vendor/symfony/event-dispatcher/Symfony/Component/EventDispatcher/EventDispatcher.php
LINE: 161
CALL: call_user_func()

FILE: [ROOT]/vendor/symfony/event-dispatcher/Symfony/Component/EventDispatcher/EventDispatcher.php
LINE: 46
CALL: Symfony\Component\EventDispatcher\EventDispatcher->doDispatch()

FILE: [ROOT]/phpbb/event/dispatcher.php
LINE: 60
CALL: Symfony\Component\EventDispatcher\EventDispatcher->dispatch()

FILE: [ROOT]/phpbb/event/dispatcher.php
LINE: 46
CALL: phpbb\event\dispatcher->dispatch()

FILE: [ROOT]/includes/functions.php
LINE: 2645
CALL: phpbb\event\dispatcher->trigger_event()

FILE: [ROOT]/includes/ucp/ucp_register.php
LINE: 50
CALL: add_form_key()

FILE: [ROOT]/includes/functions_module.php
LINE: 674
CALL: ucp_register->main()

FILE: [ROOT]/includes/functions_module.php
LINE: 998
CALL: p_master->load_active()

FILE: [ROOT]/ucp.php
LINE: 70
CALL: p_master->load()

Ken
Posts: 4
Joined: 03 Nov 2016, 17:58
Has thanked: 0
Been thanked: 0

Re: Registration submission gets SQL error

Unread post by Ken » 04 Nov 2016, 02:37

Another thing I noticed is that when the extension is disabled, the module management shows on the System tab. When it is enabled, the module management disappears. Also, when CleanTalk is enabled, the tabs show both the System and Extension active.
CleanTalk_disabled.PNG
With CleanTalk disabled, the module management links show in the System tab.
CleanTalk_enabled.PNG
With CleanTalk enabled, the module management links disappear.
CleanTalk_Extensions_enabled.PNG
The System and Extensions tabs are both active when CleanTalk is enabled.

Ken
Posts: 4
Joined: 03 Nov 2016, 17:58
Has thanked: 0
Been thanked: 0

Re: Registration submission gets SQL error

Unread post by Ken » 04 Nov 2016, 03:16

Doing a little investigation, I found that the Sessions table was not modified when CleanTalk was enabled. I'll try adding it manually to see what happens.

Ken
Posts: 4
Joined: 03 Nov 2016, 17:58
Has thanked: 0
Been thanked: 0

Re: Registration submission gets SQL error

Unread post by Ken » 04 Nov 2016, 03:37

I think the problem may have been another error I encountered before I successfully enabled CleanTalk. I have upgraded to 4.8 and it seems to be working. However, the System tab is still missing the Module Management links and the System and Extensions tabs are active at the same time.

User avatar
SergeM
Posts: 115
Joined: 27 May 2016, 08:05
Has thanked: 11 times
Been thanked: 8 times
Contact:

Re: Registration submission gets SQL error

Unread post by SergeM » 04 Nov 2016, 05:33

Hello.

Thank you for your request. Your information really helps.

We will look at this issue more closer and perform the tests in our environment.

We will contact you on the results as soon as possible.

Best regards.
———————
Technical Support
https://CleanTalk.org — Anti-Spam Modules for all CMS

User avatar
SergeM
Posts: 115
Joined: 27 May 2016, 08:05
Has thanked: 11 times
Been thanked: 8 times
Contact:

Re: Registration submission gets SQL error

Unread post by SergeM » 05 Nov 2016, 12:37

Hello.

We have tested the CleanTalk Anti-Spam Extension versions 4.7 and 4.8 but we didn't see such issues.
We believe it's the problem of your environment.

Could you create a temporary user with administrator right for us in your forum? We guarantee the integrity of your forum and will not change anything without informing you.

Please, send temporary user credentials privately via e-mail [ support@cleantalk.org ] or support ticket [ https://cleantalk.org/my/support ].

Waiting for your reply.
———————
Technical Support
https://CleanTalk.org — Anti-Spam Modules for all CMS

Post Reply