Mod won't install

Anti-spam mod for SMF.
welshdog
Posts: 2
Joined: 16 Apr 2014, 21:41
Has thanked: 0
Been thanked: 0

Mod won't install

Unread post by welshdog » 16 Apr 2014, 22:01

Hi, testing out the Clean Talk Mod for SMF. I first tried to install the Mod by accessing it via the 'Package Manager' at the SMF server. It said it installed successfully and I was then directed to go to CleanTalk for the Access Key. I did that... and clicked on 'setup anti-spam app'. This told me to download and install 'smf-antispam-1.0.zip' but as none of the available servers carried it, I followed the alternate instructions to upload it to its own directory within the packages directory on my server and reload the forum.

I did that, and nothing happened. I took the file *out* of the directory into the body of the packages directory and tried again. The Mod still didn't appear in the listings. In fact, the message I received from the SMF Download App was as follows:

"Package upload failed due to the following error:
"Although the package was downloaded to the server it appears to be empty. Please check the Packages directory, and the "temp" sub-directory are both writable. If you continue to experience this problem you should try extracting the package on your PC and uploading the extracted files into a subdirectory in your Packages directory and try again. For example, if the package was called shout.tar.gz you should:
1) Download the package to your local PC and extract it into files.
2) Using an FTP client create a new directory in your "Packages" folder, in this example you may call it "shout".
3) Upload all the files from the extracted package to this directory.
4) Go back to the package manager browse page and the package will be automatically found by SMF."

I'm now stuck. What do I do??

User avatar
shagimuratov
Administrator
Posts: 1115
Joined: 16 Mar 2011, 12:51
Has thanked: 158 times
Been thanked: 67 times
Contact:

Re: Mod won't install

Unread post by shagimuratov » 17 Apr 2014, 10:18

Hi!

Thank you for notice! We are testing your case right now, we'll let you know as finish.

Any way, can you extract archive to board via FTP? You should extract to folder SMF_ROOT/Packages. Can see the MOD at Package manager now?
WBR
Denis Shagimuratov
Project leader

psrustik
Posts: 47
Joined: 17 Apr 2014, 19:29
Has thanked: 1 time
Been thanked: 8 times

Re: Mod won't install

Unread post by psrustik » 17 Apr 2014, 19:46

Hi.
1. Our mod never contains ZIP file. Cleantalk mod use tar.gz archive.
Very strange that your SMF download smf-antispam-1.0.zip file when my SMF download file "antispam_cleantalk_smf-1.01.tar.gz".
Screen1

2. I just explored sources of SMF "Latest packages" mechanism.
SMF engine every day downloaded special data from official site which contains links and descriptions of new mods and updates.

May be a few days ago this file contained broken link for Cleantalk mod download.
But now - all ok, all links valid. Please try again.

In your SMF this special file update automatically every day. Also you may run this manually
Screen2


I see this possible ways:
1. Wait for update caches (1 day) or update them manually using the scheduled tasks.
Then install mod from package manager.

2. Download antispam_cleantalk_smf-1.01.tar.gz from mod page to your disk.
Then upload tarball by "Upload a Package" form.
Screen3

welshdog
Posts: 2
Joined: 16 Apr 2014, 21:41
Has thanked: 0
Been thanked: 0

Re: Mod won't install

Unread post by welshdog » 17 Apr 2014, 23:36

psrustik wrote:Hi.
1. Our mod never contains ZIP file. Cleantalk mod use tar.gz archive.
Please see "https://cleantalk.org/register?platform ... l_notice=1"
psrustik wrote:Hi.
I see this possible ways:
1. Wait for update caches (1 day) or update them manually using the scheduled tasks.
Then install mod from package manager.

2. Download antispam_cleantalk_smf-1.01.tar.gz from mod page to your disk.
Then upload tarball by "Upload a Package" form.
Screen3
Tried '2' and got the same result. :(

psrustik
Posts: 47
Joined: 17 Apr 2014, 19:29
Has thanked: 1 time
Been thanked: 8 times

Re: Mod won't install

Unread post by psrustik » 18 Apr 2014, 13:01

welshdog wrote: Please see "https://cleantalk.org/register?platform ... l_notice=1"
Instruction was changed, archive link corrected.

Tried '2' and got the same result. :(
Please try this:
1. If exists than uninstall and delete old "Anti-spam by CleanTalk" mod from Admin - Package Manager - Browse Packages.
2. Install mod via package manager:
In "New Packages:" section click to "Anti-spam by CleanTalk 1.01" and "Install Now!" button.
Screen

psrustik
Posts: 47
Joined: 17 Apr 2014, 19:29
Has thanked: 1 time
Been thanked: 8 times

Re: Mod won't install

Unread post by psrustik » 21 Apr 2014, 16:23

psrustik wrote:
welshdog wrote: Please see "https://cleantalk.org/register?platform ... l_notice=1"
Instruction was changed, archive link corrected.

Tried '2' and got the same result. :(
Please try this:
1. If exists than uninstall and delete old "Anti-spam by CleanTalk" mod from Admin - Package Manager - Browse Packages.
2. Install mod via package manager:
In "New Packages:" section click to "Anti-spam by CleanTalk 1.01" and "Install Now!" button.
Screen
welshdog, what is the result?

psrustik
Posts: 47
Joined: 17 Apr 2014, 19:29
Has thanked: 1 time
Been thanked: 8 times

Re: Mod won't install

Unread post by psrustik » 13 May 2014, 16:56

By welshdog from SMF community:
Did a full upgrade on the site and then reinstalled the Mods including Clean Talk. This time it worked perfectly. Disabled all other 'spam filters' etc other than Akismet.
No idea what the issue was caused by sorry.

Locked