Seeing a werid error message in my admin logs

Anti-spam MOD for phpBB3, extension for phpbb3.1
krynsky
Posts: 3
Joined: 24 Jun 2018, 17:12
Has thanked: 0
Been thanked: 0

Seeing a werid error message in my admin logs

Unread post by krynsky » 24 Jun 2018, 17:18

Hello, I'm using PHPBB 3.2.2 and this week noticed a larger than usual number of spammers getting in. I manually deleted the spammers and started looking around at my admin logs and see numerous errors like the one below:

Error while connecting to CleanTalk service
CURL error: "SSL: certificate subject name '*.cleantalk.org' does not match target host name '78.47.96.11'" or disabled allow_url_fopen in php.ini

However looking at the logs, it appears this has been going since March 5th, so really like 3 months. I still get weekly reports about spam blocking, and usually only 1 or 2 spammers make it into the forum each week at most, which is pretty good. but clearly something isn't quite right.

Also there's a section where you can check users for spam. When I tried that today I got an error "Error. No connection with blacklist database"

User avatar
SergeM
Posts: 116
Joined: 27 May 2016, 08:05
Has thanked: 11 times
Been thanked: 8 times
Contact:

Re: Seeing a werid error message in my admin logs

Unread post by SergeM » 25 Jun 2018, 06:13

Hello.

Thank you for your request.

We have fixed that error in the latest version.

Please, update the CleanTalk Extension:
https://cleantalk.org/help/update-phpbb31

Contact us anytime.

Best regards.
———————
Technical Support
https://CleanTalk.org — Anti-Spam Modules for all CMS

krynsky
Posts: 3
Joined: 24 Jun 2018, 17:12
Has thanked: 0
Been thanked: 0

Re: Seeing a werid error message in my admin logs

Unread post by krynsky » 25 Jun 2018, 15:13

Thank you SergeM,

The error I have doesn't quite match the error described on your update page, but I Ill give it a try and report back.

User avatar
SergeM
Posts: 116
Joined: 27 May 2016, 08:05
Has thanked: 11 times
Been thanked: 8 times
Contact:

Re: Seeing a werid error message in my admin logs

Unread post by SergeM » 25 Jun 2018, 15:25

Kind reminder that you can check the protection with this blacklisted e-mail:
stop_email@example.com

Don't forget to log out from your admin account before doing any tests.

Thank you.
———————
Technical Support
https://CleanTalk.org — Anti-Spam Modules for all CMS

krynsky
Posts: 3
Joined: 24 Jun 2018, 17:12
Has thanked: 0
Been thanked: 0

Re: Seeing a werid error message in my admin logs

Unread post by krynsky » 25 Jun 2018, 17:25

Thank you SergeM, I was able to successfully update my version. It shows as correct in my control panel and I got a denial of registration when using a known bad email test@cleantalk.org so overall that looks good, I don't see any errors in my logs, I'll just keep watch for a few days.

Thought I still had an error when checking my users for spam still but I tried it again an that seems to be working, so thank you for your help!

User avatar
AMags
Posts: 42
Joined: 05 May 2017, 08:31
Has thanked: 0
Been thanked: 3 times

Re: Seeing a werid error message in my admin logs

Unread post by AMags » 26 Jun 2018, 05:42

You are welcome.

Feel free to contact us anytime.

Best regards.
Technical Support
https://CleanTalk.org — Anti-Spam Modules for all CMS

Post Reply